help, please (about mp3 player) - VeggieBoards
Forum Jump: 
 
Thread Tools
#1 Old 04-10-2005, 12:52 PM
Newbie
 
rosie's Avatar
 
Join Date: Jul 2004
Posts: 48
i just got a creative zen touch 20g player & i'm having a problem with it.



yesterday it was working fine, but then i charged it... NOTHING shows up on the screen. i've tried restarting it& everything but only the backlight comes on for just a while (i turned it off before it went all screwy). i don't know. it still plays music.



any idea? i hope it's something really obvious that i'm missing.
rosie is offline  
Sponsored Links
Advertisement
 
#2 Old 04-10-2005, 01:49 PM
Banned
 
remilard's Avatar
 
Join Date: Nov 2003
Posts: 5,772
Thats weird, has the player been dropped etc recently?



The first thing to try would be a hard reset, there should be a small hole somewhere on the player that you can gently insert a straightened paper clip into until you hear/feel a click.



The second thing to try would be updating to the newest firmware (or reloading the firmware if you already have the latest version).



Beyond that I'm not sure what could be done. If neither of the above work, and the player is under warranty, I would send it in for replacement. My mildly educated guess would be that a physical connection has been compromised in the player, which is definately a manufacturer's defect (any shaking, dropping etc would wreck the hard drive long before it would damage sound solder points.)



Good luck.
remilard is offline  
#3 Old 04-11-2005, 12:44 PM
Newbie
 
rosie's Avatar
 
Join Date: Jul 2004
Posts: 48
no, i didn't drop it or anything like that. i remember setting it down & seeing the battery charge thingee light up on the screen, then when i picked it up again... nothing.

restarting it didn't work.

damn.

oh well. thanks for the advice!
rosie is offline  
Sponsored Links
Advertisement
 
#4 Old 04-11-2005, 01:11 PM
Banned
 
remilard's Avatar
 
Join Date: Nov 2003
Posts: 5,772
At least try reloading/updating the firmware, the manual explains how to do this. If it is a software problem, that will fix it.
remilard is offline  
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the VeggieBoards forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in


Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off